Bienvenue sur http://eagle-usb.org




Participer à eagle-usb.org

Vous pouvez participer à la vie collaborative de ce site et proposer vos propres articles en vous inscrivant ci-dessous. Indiquez ici votre nom et votre adresse email. Votre identifiant personnel vous parviendra rapidement, par courrier électronique.

Votre nom ou pseudo

Votre adresse email




IMPRIMER Format imprimable
Driver eagle-1.0.3
par Stéphane .Co

Depuis quelques jours les plus curieux d'entre vous et les habitués du forum ont pu tester une nouvelle version du driver estampillée eagle-1.0.3 ; tiens mais le cc a disparu ! ? eh oui cet acronyme barbare qui dissimulait (pour les incultes ;)) le nom de notre ami Christian Casteyde, qui, après plusieurs mois de dévouement, laisse place à une nouvelle équipe de développeurs.

Certains d'entre vous l'ont sûrement croisé sur le forum ou sur la mailing liste, SL33P3R nous livre donc sa première version :

Celle-ci corrige plusieurs bugs :

-  un oops introduit par la cc5 (quand on rmmod)
-  un kernel panic possible quand le adictrl -d vient trop vite après le adictrl -f
-  Quelques memory leaks

Elle contient les améliorations suivantes :

-  Support multi-modems (par rguerin@freebox.fr). Testé avec 8 modems
-  Boot de-synchronization .. Pour ne plus avoir de freeze lors du reboot
-  Affichage des dBs


N'hésitez pas à visiter le site de Christian où vous pourrez déguster de nombreux documents fort bien écrits : http://casteyde.christian.free.fr et faites vos révisions avec son YAGIL

eagle-1.0.3.tar.gz - 1 Mo
eagle-1.0.3.tar.gz
(GZ, 1 Mo)


A SAVOIR

Regardez la dernière version stable que vous pouvez télécharger : la 1.0.4 à ce jour

Le forum vous accueille en cas de problème d'installation (inscrivez-vous !).






COMMENTAIRE(S) DE L'ARTICLE :

Forum de l'article

  • Driver 1.0.4
    11 juillet 2003

    Tout marche bien a faible debit, mais des que ca monte ca casse.

    J'ai controle pppd avec des log est en lui demandant de ne pas ccrocher avant d'avoir manque comme 5000 lcp en envoyes a une seconde d'intervale.

    En revanche passer quelques options a pppd permet de rendre la connection plus rapide.

    Dans les log RIEN de particulier, ie pppd ne dit rien de special, pppoa rale parfois au debut sur des paquets asynchrones. Si je met un time out sur pppoa cela ne sert a rien.

    pppoa[1086] : Wrong length field in incoming data 176pppoa[1086] : read (AsyncReadFromPPP) : Input/output error80 (342)

    Il semble que le probleme vienne de pppoa, pas sur en tout cas le lien est deborde, les buffers explosent ..

    Je suis avec les debits par defaut (1492) en emission reception.

    Deuxieme remarque la version de mon noyau est mal detectee par le Makefile, il suppose que le noyau est dans /usr/src/linux et utilise des variantes de uname cependant il detecte une autre version que celle donnee par uname.

    Je dois donc forcer le chargement du module avec isnmod -f, les modules sont cependant mis dans le bon repertoire de modules.

    J'ai pas trouve l'option de compilation qui determine la version de linux des modules compiles.

    Nota c'est juste l'extra version qui foire.



  • Bah voila, g suivi les procedure, g tout c message d'erreur, galere galere
    3 juillet 2003, par myz-rix
    Génération des fichiers de configuration réussie. mkdir -p /etc/hotplug/usb /usr/bin/install -c -m 0644 -o root -g root options.adsl /etc/ppp /usr/bin/install -c -m 0644 -o root -g root options.mire /etc/ppp /usr/bin/install -c -m 0600 -o root -g root pap-secrets /etc/ppp /usr/bin/install -c -m 0600 -o root -g root chap-secrets /etc/ppp /usr/bin/install -c -m 0554 -o root -g root hotplug/adiusb* /etc/hotplug/usb /usr/bin/install -c -m 0644 -o root -g root usb.usermap /etc/hotplug /usr/bin/install -c -m 0554 -o root -g root adsl/* /usr/sbin rm -f options.adsl options.mire pap-secrets chap-secrets usb.usermap make[1] : Quitte le répertoire `/usr/local/src/eagle-1.0.3/scripts' [root@Berseker eagle-1.0.3]# startadsl Unable to open any supported device ! Please check your modem is connected and (re)send it its firmware ! Unable to open any supported device ! Please check your modem is connected and (re)send it its firmware ! SIOCSIFNETMASK : Aucun périphérique de ce type 192.168.60.30 : interface inconnue : Aucun périphérique de ce type [root@Berseker eagle-1.0.3]# adictrl -f /etc/analog/firmware.bin Unable to send the firmware to the modem : Function not implemented

    • meme probleme
      13 septembre 2003, par fab

      bonjour, j'essaie d'installer le modem fast800 sous une debian woody et j'ai le meme message que toi quand je fais un /usr/sbin/startadsl :

      Unable to open any supported device ! please check your modem is connected and (re)send it its firmware !

      je sais pas quoi faire, si quelqu'un a des infos a me filer, ca serait cool !



  • > Driver eagle-1.0.3
    18 mai 2003, par titeuf
     \1 Jen peu plus je n'arrive po a installer ce driver ( ni ceux de SAGEM d'ailleur) j'ai une RH 8.0 fraichement installé mais il plante lors de la compîlation du pilote

    • > Driver eagle-1.0.3
      18 mai 2003, par ben

      pour la redhat 8 consulte la page de nicolas delattre elle est bien faite et je n'ai eut aucun probleme pour installer free adsl. Ma connection marche bien tout nikel. Voila ben.

      http://delattre.nicolas.free.fr/freeadsl/DW020224.htm



    • > Driver eagle-1.0.3
      22 mai 2003, par joreno
      bonjour, dans etc/usr/ tu dois créer un alias (ln -s linux-2.4.18-14 linux). Ton pilote a besoin de trouver celui-ci sur sa route pour s'installer correctement.

    • > Driver eagle-1.0.3
      29 septembre 2003, par cpbcb
      moi g mis le driver de sagem version 2.0.3 et ca marche nickel... Reconnexion auto... va sur la page http://delattre.nicolas.free.fr/freeadsl/DW020224.htm. c super bien expliqué et mets le protocole pppoe. le pppoa n'est pas stable.


  • > Driver eagle-1.0.3
    14 mai 2003, par PI

    Installation OK \1 Juste un problème de déconnexion qui arrive aléatoirement. L'interface ppp0 disparait (Il faut relancer startadsl pour la voir réapparaitre), par contre l'interface ethx est toujours là.

    Qqu'un a déjà rencontré ce phénomène ?

    PS : Je peux rester connecté plusieurs jours sans rencontrer le problème.



    • > Driver eagle-1.0.3
      25 septembre 2003, par mathieu 7-7

      Moi ! j'ai le même problème que toi avec une Mdk 9.1. (disparition PPP0, connection aléatoire)

      Le truc vient peut être d'un chipset USB foireux ? Moi c'est du VIA (Epia Mini-itx)...



  • > Driver eagle-1.0.3
    11 mai 2003, par plit

    Hyper Extra Mega ... (les superlatifs ne suffisent pas) génial ! ! ! ! J'utilise un système à base de LFS et TOUT fonctionne correctement.

    Hyper Extra Mega ...bravo et merci !



  • > Driver eagle-1.0.3
    6 mai 2003, par Gaby13[ :)]
    Genial ! un grand bravo à tous ceux qui ont fait aboutir ce driver \1 Du premier coup avec les tres bonne explications qui accompagne ce driver !

  • > Driver eagle-1.0.3 Petit probleme
    2 mai 2003, par Pascal
    J'utilise RedHat 7.3 : aucun probleme pour le driver et la connexion. Mon probleme vient que du fait une quinzaine de fois par jour, la connexion ne fonctionne plus pendant 1 à 2 minutes. L'interface ppp0 est toujours presente (verifié avec ifconfig), la table de routage est bonne (verifié avec route). Puis tout cela rentre dans l'ordre. Est ce le probleme de LNS de Free ? Ca me gene pas vraiment mais j'aimerais comprendre....

  • > PB avec Driver eagle-1.0.3 + rh8.0
    19 avril 2003, par niko

    Bonjour, moi g eu des pb pour l'installation : [root@localhost eagle-1.0.3]# make clean make -C driver clean make[1] : Entre dans le répertoire `/usr/local/src/eagle-1.0.3/driver' Makefile :54 : /usr/src/linux/.config : Aucun fichier ou répertoire de ce type make[1] : *** Pas de règle pour fabriquer la cible `/usr/src/linux/.config'. Arrêt. make[1] : Quitte le répertoire `/usr/local/src/eagle-1.0.3/driver' make : *** [clean] Erreur 2

    J'ai pourtant mis les sources de kernel dans /usr/src/linux mais il n'y a pas le .configure Donc je ne sais plus comment faire Je suis sous red hat 8.0 Merci



    • > PB avec Driver eagle-1.0.3 + rh8.0
      28 avril 2003, par coolbord
      moi aussi exactement le meme message jai mandrake 9.0 ou se trouvent les sources du kernel ? elles sont deja installées apparemment

  • > Driver eagle-1.0.3
    6 avril 2003, par Risk

    super le driver eagle, avec mdk 9.0 Ne m'y connaissant que tres peu sous linux, le driver eagle a ete plus simple a installe que celui fourni par sagem. Celui de sagem se deconnectait grave souvent, que le eagle, il ne s'est pas deconnecte (tout seul).

    Par contre, je n'ais pas reinstalle mdk avant de mettre le driver (la flemme de reinstaller), ce qui doit foutre le bordel car les fichiers du driver sagem sont toujours la. Mais ca marche tout de meme tres tres bien.

    En resume, merci (et je ne suis pas le seul a le penser).

    Linux POWAA ! !



  • > Driver eagle-1.0.3
    27 mars 2003, par desmodingo

    Arithmétique du jour : Mandrake 9.1 + 1.0.3 + Installation clean (suppression de tout pppoa ou adiusbadsl présent sur la machine) = LA fuite mémoire habituelle de 4K par trame PPP \1

    Le chargement du driver est OK ; La configuration de l'interface est OK ; Le binding sur PPP est OK ; Ma méoire fond à grande vitesse, OK \1

    Donc on continue à chercher !

    Chris



    • > Driver eagle-1.0.3
      2 avril 2003, par Nosf
      Personne n'a réussi à installer correctement le modem sous mandrake 9.1 ? ? ? perso j'ai pas réussi \1 si qq pouvait m'aider !

      • > Driver eagle-1.0.3
        6 avril 2003, par bab
        Pareil , fuite de mémoire. (Mandrake 9.1 + Eagle 1.0.3). Mais ça ne m'empeche de travailler. Ca baigne. Au niveau installation de ce driver, rien à faire, c'est tellement facile, je l'ai installé en regardant le lisezmoi.txt. En tout cas, bravo !

        • > Driver eagle-1.0.3
          10 avril 2003, par Chatmann

          Bon okay je suis une glaire en linux... Tout marchait bien sous Mand 9.0, tout foire sur Mdk 9.1 ... Pour les fuites je n'en sais rien, je n'arrive meme pas a configurer l'interface eth0 avec adictrl -i ...

          Donc j'espere que qq'un a trouve comment installer ca proprement sous 9.1, car elle commence a me les briser menu cette version (je n'ai meme plus de X en ce moment, mais ca je sais pourquoi...)

          Chatmann



          • > Driver eagle-1.0.3
            12 avril 2003, par bab
            Salut, Je me suis rendu compte que Mandrake 9.1 reconnait le modem Sagem 800 sans aucune installation manuelle. Cool. Si tu n'as pas encore reussi, passes par DrakConf. Mais si tu n'as pas X ça devient compliqué.Mais je t'assure qu'il n'y a vraiment rien à faire... La version de driver fourni avec Mandrake 9.1 est une version 1.0.2.

            • > Driver eagle-1.0.3
              23 avril 2003

              ok avec drakconnect, mais apres la configuration du compte et du mon de passe sur la fenetre suivante il me presente une liste de module mais adiusbadsl n'y est pas !

              je reste bloqué !

              alors que le rpm du kernel installe deja ce module ! ! !

              comment faire, merci ...



              • > Driver eagle-1.0.3
                24 avril 2003, par bab
                Salut, fais un insmod adiusbadsl. S'il n'y a pas le module, c'est qu'il est égaré quelque part. Regardes si dans le dossier /lib/modules/2.4.21-0.13mdk/kernel/drivers/usb/adiusbadsl/ le fichier adiusbadsl existe ? Sinon, je te conseille de resinstaller le kernel : rpm -ivh --force kernel-2.4.21.0.13mdk-1-1mdk... Ca va remettre le module en place. Et redémarres ton PC.

  • > Driver eagle-1.0.3
    26 mars 2003
    clapclapclap franchement BRAVO ! tout marche sans pb.  \1 ( Mandrake 9.0 )

  • > Driver eagle-1.0.3
    20 mars 2003, par Fusco

    Bonsoir, je fait parti de l'équipe knoppixfr. et suis surtout le responsable du dévoleppement du script adslconfig. qui comme son nom l'indique sert à configurer la connexion adsl. J'en suis arrivé à votre modem, celui ci devient de plus en lus répandu. Cette distribution étant destiné à des "non-connnaisseurs" de linux, et encore moins de la ligne de commande. je suis donc à la recherche d'une installation par paquets debian afin de configurer votre modem.

    J'ai demandé à un de mes collaborateurs qui utilise ce modem , de faire les test d'installation. il a utilisé les 3 paquets debian (fourni par le lien du debut de mois)

    Mais à mon grand regret, la connexion ne se fait pas, mon collaborateur me dit, qu'il a un message comme quoi le modem n'est pas trouvé (et il n'y a aucune activité sur le modem)

    Si quelqu'un pouvait me fournir, la marche à suivre en utilisant ces paquets.

    Cela nous permettrez dans un premier temps de les faires installer via notre script. dans un second temps, si les licences le permettent, de l'incorporer a flonix, qui est une distribution basé sur knoppix mais tout en fr qui elle tiendra sur une galette de 210Mo

    ps : les VPI VCI login et pass sont bon \1



    • > Driver eagle-1.0.3 erreur Modem pas connecté
      28 mai 2003

      J'ai essayé le driver fourni par Sagem, mais pas encore celui de CC.

      Pour "modem non reconnu", j'ai résolu ce problème en le branchant sur un autre port USB (curieux tout de même que le port USB de la carte mère ne fonctionne pas ! ! !) en tout cas après, le modem était reconnus et j'ai pu poursuivre mon installation.

      Maintenant, si je suis ici, c'est parce qu'a la fin je ne pouvais tout de même pas me connecter....(surement pour d'autres raisons)
      -  Modem non branché ? essayez de le brancher sur un autre port.



  • upgrade
    20 mars 2003, par sam

    salut a tous y a t-il une procedure simple pour le passe de la 1.0.2-cc5 a la 1.0.3 sans tout recompiler \1 ?

    merci



  • Parfait sauf...
    20 mars 2003, par Gwenn

    D'abord merci pour ce driver... J'ai installé les paquets debian, j'ai mis à jour le paquet 'hotplug' mais : j'ai eu cette erreur : No CHAP secret found for authenticating ... \1 J'ai essayé avec PPPOE et j'ai eu cette erreur : pppoe : Timeout waiting for PADO packets... \1 Je suis repassé à PPPOA et j'ai modifié le fichier 'options.adsl' et là, hop, j'arrive à me connecter \1 J'ai ensuite fait une petite analyse et j'espère ne pas me tromper mais : 'options.adsl' et 'options.mire' sont générer à partir de 'options' qui se trouve dans /etc/ppp en ajoutant la ligne user 'monlogin' qui va bien. Si le fichier 'options' est d'origine (je crois que c'est mon cas), alors la connection ne s'établit pas. En utilisant le fichier 'options' du driver (dans scripts/ppp) et en rajoutant la ligne user 'monlogin' la connexion s'établit

    Voila !



  • > Driver eagle-1.0.3 (debian)
    20 mars 2003, par Panard

    Voici ma source apt où les utilisateurs de Debian pourront télécharger les 3 paquets de ce driver.

    deb http://www.inzenet.free.fr/debian ./

    puis

    $ apt-get update

    $ apt-cache search eagle

    le nom des packages à installer s'affiche. reste plus qu'à faire un

    $ apt-get install

    pour l'install du module, une fois le paquet kernel-patch-eagle-adsl installé :

    $ cd /usr/src

    $ tar xfz eagle-adsl.tar.gz

    $ ln -s linux

    $ cd linux

    $ make-kpkg modules_image

    $ cd ..

    $ deb -i eagle-adsl-modules..deb

    voilà, j'espère n'avoir rien oublié.

    Si vous rencontrez un pb sur ces paquets debian (uniquement si vous etes sur que ca vient des packages téléchargés depuis ma source) :



  • Un seul mot : extra...
    17 mars 2003, par DrWatson

    Tout d'abord un grand bravo à toute l'équipe qui a mis au point ces drivers, c'est tout simplement magique ! J'étais habitué au PPPoE avec des modems ethernet et là, j'avais peur de me galérer un peu sous Linux avec le F@st 800 de Sagem. Il n'en est rien !

    J'ai une Debian 2.4.18-bf2.4 (un noyau générique compilé par Debian) sur un vieux PIII et ca marche nickel de chez nickel ! J'ai installé les headers pour cette version de Kernel, je les ai compilé les drivers, j'ai tapé "make install" et après un petit "startadsl" et hop, on the Net en 5 minutes chrono... \1

    Tout marche impec, y compris le package hotplug (j'ai installé la version testing de ce paquet car c'était conseillé). L'USB ne déconne jamais, il me trouve le modem, l'initialise tout seul comme un grand... Pas une erreur au Boot non plus...

    Vraiment extra... Il me reste maintenant la reconnexion avec un petit script maison (avec un test par ping pour l'histoire de la mire ADSL)... Voilà, ravi d'avoir choisi Free, c'est pas cher et ca marche sous Linux, que demandez de plus ? ? ? \1



    • > Un seul mot : extra...
      19 mars 2003, par turboo
      Juste pour dire que j'ai installer les drivers sous gentoo et que ca fonctionne parfaitement. Felicitations

    • > Un seul mot : extra...
      29 mai 2003

      Tu voudrais bien nous donner les détails de la compilation ? (ce qu'il faut taper au fur et à mesure, étape par étape)

      Et les headers, qu'est ce que c'est ?

      Merci



  • Driver eagle-1.0.3 pour Debian
    7 mars 2003, par Roland Mas

    Des paquets Debian sont dispo sur ma page ouèbe de chez Free.

    Ces paquets génèrent le module noyau, insèrent la conf' hotplug, créent la conf PPP pour ADSL (par trois questions Debconf), et ne proposent pas de script d'init spécifique (on passe par ppp_on_boot). Ils proposent également l'utilisation de adsl.daemon, qui relance la connexion au besoin.



    • > Driver eagle-1.0.3 pour Debian
      7 mars 2003

      \1

      J'ai installé et configurer ce modem pour un copain sur une jolie Debian.

      Pb, sur son secteur pppoa déconne gravement alors je l'ai passé en pppoe et plus de pb.

      Est ce que les scripts d'installation permettent de choisir entre pppoa ou pppoe ?



    • > Driver eagle-1.0.3 pour Debian
      13 mars 2003, par vincent
      Peux tu expliquer un peu comment se passe l'install de ces paquets ? Les .deb sont ils applicables sur toutes les versions de debian ou faut il recompiler ? Est il possible d'utiliser eagle_init avec ces paquets ?

      • > Driver eagle-1.0.3 pour Debian
        14 mars 2003

        J'ai fait un dpkg- L pour voir et pas de script pour choisir pppoa ou pppoe.

        Bref, ce n'est pas trés grave, puisqu'il n'y a pas grand chose à modifier pour passer en pppoe. Faudra que je prenne le temps de faire un script de choix avec vérification de la présence de rp-pppoe.

        Vincent > Que tu utilise le paquet Deb ou que tu compile tu auras la même chose.

        Si tu ne te sens pas à l'aise avec les tar.gz utilise le paquet.



        • > Driver eagle-1.0.3 pour Debian
          27 mars 2003, par smarechal

          Hello,

          pardon pour mon ignorance sous linux, je m'y met petit a petit, je voulais savoir si il est facile pour un debutant (linux) d'installer le modem sagem fast800 ? Car j'aimerais me passer de windows, mais sans internet c'est pas cool \1 Merci de vos réponse



          • > Driver eagle-1.0.3 pour Debian
            1er avril 2003
            Si tu débutes complètement et que tu te tapes la doc en entier, tu risques d'être un peu perdu. Par contre, avec une recette bien ficelée à suivre point par point, tu devrais effectivement être connecté en deux minutes ...

            • > Driver eagle-1.0.3 pour Debian
              4 avril 2003

              Bonjour a tous , cela fait quelques jours que j'essaye également avec vos explications sur cette page et d'autre sur le web de connecter mon modem sur une machine linux . Plus j'avance et moins ca marche . \1

              Mon dernier essai : Lessivage de la machine, mise en place d'un noyau 2.4.18 bf24 avec header et sources .

              Récupération de packages sur www.inzenet.free.fr /...

              installation des packages installation du module comme suit : cd /usr/src tar xfz eagle-adsl.tar.gz ensuite aprés décompilation des sources : création du lien : ln -s kernel-source-2.4.18 linux récupération du .config de /boot vers usr/src/linux cd linux

              make-kpkg modules_image (on a besoin du package dephelper pour cette étape) cd ..

              dpkg -i eagle-adsl-modules....deb (paquet créé précédemment)

              J'ai récupéré également le hotplug derniére version .

              Pour arrivé a : pas grand chose . \1

              dans var/log/syslog : je vois depuis cette derniére install que

              ..USB device is not claimed by any driver

              alors que sur mes précédents essais le driver était ok mais des messages commes ceux ci apparaissait :

              modprobe : can't locate modules down .. modprobe : can't locate modules 192.168.60.30

              Je suis un peu long dans mes explications ,je m'en excuse mais j'aimerais réussir ,peut étre grace a vous A+ Bernard